Adding Scenes & Content To Your Webpage Layout
OK. So now we have a basic layout mapped out.

We just need to prepare all your content, photos, bios, text, articles, illustrations, images, CVs, whatever information and items you want to show off on your own personal portfolio website.
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First of all, lets replace the background with something a bit more stylish.

Step 1

First off a quick summary of the Toolbar and Panels in PHOTOSHOP CS4. Open Photoshop and observe the tools on the left side and the panels on the right side.

Phototshop has grouped many related tools together, with one tool in the group visible in the Tools panel and the others hidden behind it. Whenever you see a tool in the Tools panel with a small arrow to the bottom right of the icon, it means there are additional tools behind it waiting to be selected, and if you click and hold your mouse button down on one of these tools, a fly-out menu will appear showing you the additional tools.
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Along the right side of the screen in Photoshop CS4 is where we find the Panels column (panels were known as palettes in earlier versions of Photoshop). Panels give us access to all kinds of commands and options for working on our images, from organizing layers and viewing individual color channels to choosing colors, stepping back through history states, working with text, viewing information about our images, and so much more.
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Before we can actually get started on the lighting effects, we need to create a background for the effect. We can’t simply use any background we choose, but rather create an appropriate canvas to begin with. Find a photograph to use as the basic palette for your background. It can be any image really… just make sure it has a lot of lights and darks in it. Alternatively, you can download the photo sample and work with the one used in the tutorial below: 

http://www.floobynooby.com/IPUB/forest-photo.jpg
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Open this forest photo in Photoshop (or ANY photo you’d like, it really doesn’t matter, as long as it’s nice and big).

Step 2

From here, we need to apply a very strong Gaussian Blur to our Photograph. Go to Filter > Blur > Gaussian Blur, and bring the slider to something high. You really want to get rid of all the detail in the photo, and have all the colors mesh together. I applied a Gaussian Blur of 75.
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Step 3

Now we are going to drastically change our background by adding a Color Balance Adjustment Layer. To create this layer, go to Layer > New Adjustment Layer > Color Balance. A “New Layer” box may pop up, just click OK.Next you’ll see in your Adjustments tab on the far right of the screen having 3 different sliders, as well as 3 separate ranges to choose from (Shadows, Midtones, and Highlights). At this point, it’s really just about experimenting with the sliders in each range until you find a suitable result. If you’re using the photograph I supplied, these were the values I used: Shadows: -37, -40, 7 Midtones: 15, 62, 0 Highlights: -34, 0, 69
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Step 4

That’s it for the background. We’re done with it. You may choose to edit your Color Balance layer later on (just double click the icon next to it), but otherwise, we can move onto the effect. 

To begin we can first zoom out (type in 50% in the bottom left corner of your window).
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Then select the Elliptical Marquee Tool from your toolbar.
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Make a large selection spanning all the way across your canvas. You may need to move your selection while making it in order to make such a large selection. If you need to do this, hold the spacebar while dragging your mouse (Don’t let go of the left mouse button). 
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You should end up with a slightly curved selection that covers at least half the canvas.
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Step 5

You can zoom back in now. Create a new Layer (Above the Adjustment Layer, mind you), and grab your Brush tool from the toolbar. 
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Find a large brush around 300, and make sure it’s set to hardness: 0 (as shown above). Choose White as your foreground color. This part may take some trial and error, but essentially, you are going to brush just the very inside of the selection you just made. Try to brush evenly across the whole selection.
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Step 6

Now set the blending mode of this layer to Overlay. 
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Deselect everything (Ctrl + D). Now, transform this layer so that it is positioned near-vertically along the right side of the canvas. To transform, go to Edit > Free Transform, or Ctrl + T. Bring your cursor close to the corner edge of your selected image, when your cursor changes to a rotation icon, click and drag to rotate the image until you place it at angle similar to what’s below, then double click on the image to apply the transformation.
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Step 7

Repeat steps 5 and 6 once or twice, and use smaller brush sizes (and then again with a much larger brush size). Be sure to put each new band of light onto a new layer!
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Step 8

Now that we have 2 or 3 different bands of light, we won’t need to make anymore of them. Instead, you can Duplicate the layers you’ve made (right click on the layer and choose Duplicate), and Freely transform them to become new shapes. Remember, Ctrl + T to transform. You can get some interesting effects by holding the Alt, Ctrl, and Shift Keys while dragging the transformation corners.
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Step 9

That’s really all there is too it! For added effect, you can add some extra color into it using Color Balance layers (like we did in step 3). The Color Balance Adjustment layer will automatically create a layer mask so that it only gets applied over the selection you made. 

To select ONLY the light streak, click on the layer you wish to change the color to, Press Ctrl+a to select all, click on the Arrow tool (first one on the tool bar) click on the light streak, then press the right and left arrow keys (separately one after the other). This will select only the light streak and now add the Color Balance Adjustment layer. Just be sure that these new adjustment layers are on top of the lighting layers.

You can play around with these until you’re satisfied with whatever colors you want.
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Step 10

So now that we’ve completed our abstract BG art, save the file. File > Save As > name the file “BG” and change the format to JPG.

Open your Flash website layout you prepared last week with basic buttons and title.

Make sure your background layer is unlocked, click on the keyframe (thus selecting the temporary gradient you had created) and press Delete to remove.
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Now go to File > Import > Import to Stage…
Choose the JPG image you created from Photoshop.

It should line up perfectly to the top left corner, if it’s not covering your white canvas, press ‘Q’ to activate the Transform tool and expand (or shrink) the image to fit.
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Step 11

Change the ESSENTIALS tab in the top right corner to ANIMATOR, to make things easier for you to navigate around.
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Go to the Scenes tab on the left and make 4 new scenes by clicking on the tiny paper icon on the bottom left four times.

[image: image24.png]Acn

Scene,

& scene 1
& scene2
& scene3
& Scene 4
& Scene’s

E°E]





Step 12

Now you have 5 scenes, click on Scene 1.

Lock all your layer except the ‘buttons’ one.
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Right click on your first button on the stage (mine was the ABOUT button).

Choose Actions.
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Make certain your Script Assist button is activated (you’ll know if there’s a big blank area above it).
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Under Global Functions > Timeline Control click and drag the “goto” text to the mini stage on the right.
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Now go up to the Scene: section above and to the far right click the arrow to select Scene 2 from the drop down menu.
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To return to your timeline, click on the tab at the top.
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Repeat this process 3 more times for the remainder of your buttons.
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For each button have it go to the next scene.

Step 13

Now you’ve finished selecting, right clicking > Actions for every one of your buttons, setting them to go to a separate scene.  Now let’s get those scenes ready for you to add your stuff into them.

First, click on Scene 2.
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Create a couple new layers.
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Rename the bottom layer “background” (double click on the text of the layer to rename it).
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Zoom out (press M, then hold down ALT and click on the stage) now you can see all four corners of the stage clearly.

Choose the Rectangle tool.
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Go to the stage and click and drag from one corner to the next, cover all the white of the canvas.
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Step 14

Now to customize the paint of this backdrop.

Go to the far left and in the Color tab, choose Radial for your Type.
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Now click on the first color tab to pick a new color for the start of your gradient.
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After choosing your two different colors, you can now grab the Paint Bucket tool and paint the rectangle with it.
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Wherever you click, that’s where the gradient will begin.
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Step 15

Lock that background layer when you’re done tinkering with it.

Click on the next layer up, then go to the Text tool, and click on the stage.

Don’t worry you’ll be able to move the block of text later.

Start typing (or copy/paste from a previously written document) or Bio, or the purpose of this site, or an introduction to your work experience and why this site is created and viewed. Basically, a generic cover letter of sorts.
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When you’re done writing your blurb of text, grab the selection tool to drag the text to the right spot.

Step 16

To change the font, size and color (now that you still have the text selected, go to the right, you’ll see the Properties window has many different options for you to customize your text.
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Step 17

With your text finalized, lock that middle layer on your timeline, rename it “text”, and rename the top layer “button”, then select that layer.
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Now we must create a back button to get back to the main page (clear and easy navigation through someone’s website is important).

Select the Text tool, click on the stage, type out “BACK”.

Select the text, go to Modify > Convert to Symbol…  Choose Button for the Type and name the symbol “back button”.
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Step 18

Make a new layer and drag that layer underneath of your text.

Now we’re ready to add a box behind the text.
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Select the Rectangle tool, pick your colors, and click and drag a shape around the text on the stage.
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Nice and simple, now we can complete the button by selecting the two key frames, and drag them over to the next frame (while holding down the ALT key).
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Do the usual customization of your button any way you’d like, larger smaller, different colors, whatever for each frame, but leave the “HIT” frame alone, that the area that is affected by your button.
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To go back to the main timeine for this scene, click on the “Scene 2” button under your timeline.
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Step 19

Right click on your BACK button, choose Actions and go through the same process as usual; drag the “goto” text to the white area, and change the Scene: to Scene 1.
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Now from the SCENE tab on the far left of your screen, click on Scene 3.  This is the scene for my Photography button, but it could be your Graphic Design section or whatever you wish (make sure the button matches the scene.  You must now start to import your content, you have all your content ready right?…. right?  Ok, let’s assume you do. 

Step 20

If you’re importing your own personal graphics, logos, illustrations, designs, or photographs, make sure you resave them from Photoshop first and make sure you shrink them down first before importing them into Flash; A) because it will make the file load up faster for when you publish your site, and B) to make the file more manageable and by keeping it low resolution makes it a deterrent for anyone who would try to steal your work.

To import your bitmaps, you do so in the same way you imported that Photoshop background earlier.   File > Import > Import to Stage…

Select your file(s), click OK, they will appear on your stage.
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You can now actually select and delete all the photos you’ve imported, we can drag them on individually later from your Library.  Everything you import, whether it be audio, video or images, get stored in the Library including all the symbol you create.
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Step 21

So once you imported all your photos (and deleted them from the stage, open your Library tab.

You can click and drag the individual images from the Library window to your stage. You can choose one at a time, or several (I imported 6 images, and I’m placing 3 per page).

Make a new layer.  Create a background for it (same way you did earlier, or copy and paste it from Scene 2).
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Make another new layer, name it “buttons” (rem=name your other layers while you’re at it so you don’t get lost)
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With your colored background gradient, your photo(s) setup, now we need to navigate through these images, and lay out some more.

Step 22

Click and drag to select all 3 frames from the first to the last layer.
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Then press F5 to add a frame.
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Now select the second frame of the second layer, press F6, then DELETE.

If it didn’t wipe out the photos you had, then just unlock the photos layer and hit DELETE again.
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Now drag on the new set (or individual) photo of your choice.

The arrangement, number of photos/graphics, and layout/colors you choose are entirely up to you.
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Now lock your photos layer and select the first frame of the top layer.
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Create a NEXT button in the same way you created the BACK button earlier…

Step 23

Select the Text tool, click on the stage, type out “NEXT”.

Select the text, go to Modify > Convert to Symbol…  Choose Button for the Type and name the symbol “next button”. Make a new layer and drag that layer underneath of your text.

Now we’re ready to add a box behind the text.

Select the Rectangle tool (or the Oval tool), pick your colors, and click and drag a shape around the text on the stage.

Nice and simple, now we can complete the button by selecting the two key frames, and drag them over to the next frame (while holding down the ALT key).

Do the usual customization of your button any way you’d like, larger smaller, different colors, whatever for each frame, but leave the “HIT” frame alone, that the area that is affected by your button.

To go back to the main timeine for this scene, click on the “Scene 3” button under your timeline.

Right click on your NEXT button, choose Actions and go through the same process as usual; drag the “goto” text to the white area, but this time choose Type: “Next Frame”.
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Step 24

Still with the Library open, and working on the top layer, click and drag your old BACK button and place it on the stage somewhere.
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Right click on your BACK button, choose Actions and go through the same process as usual; drag the “goto” text to the white area, and change the Scene: to Scene 1.

You can unlock the photos layer and keep adding more and more content, press F5 to add frame on the timeline, if you make a mistake Ctl+Z to UNDO.  If you accidentally double click and it brings you into the symbol, you can just double click anywhere on the stage to bring you back where you were.

SAVE OFTEN! Flash can crash at random times, press Ctl+S after everything you do to save an up to date version of you website, save it on your workstation’s “D drive” or on your USB.

Step 25

Repeat this process in a similar way for your next scene (my website was setup to be the Resume for the 3rd button). Click on Scene 4 in the far left tab to get into that fresh new timeline.  Copy/paste your old background (or create a new one), create a new layer, copy/paste your resume (or at least a condensed version of one) into a block of text. Make sure to add a layer for your back button, drag the symbol in from your Library, set it to go back to Scene 1.
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Now all we need to do is fill out our contact info.

Click on the Scene 5 text to the far left of your screen.

Type out your email address, plus any other info you’d like to share, your Linkedin address, your phone number, your Twitter, your MSN Messenger, your Skype, your iChat, etc.

Step 26

Once you’ve setup your email text, 

Select the text, go to Modify > Convert to Symbol…  Choose Button for the Type and name the symbol “email button”.

Make a new layer and drag that layer underneath of your text.

Now we’re ready to add a box behind the text.

Select the Rectangle tool, pick your colors, and click and drag a shape around the text on the stage.

Nice and simple, now we can complete the button by selecting the two key frames, and drag them over to the next frame (while holding down the ALT key).

Do the usual customization of your button any way you’d like, larger smaller, different colors, whatever for each frame, but leave the “HIT” frame alone, that the area that is affected by your button. To go back to the main timeine for this scene, click on the “Scene 5” button under your timeline.

Right click on your email button choose Actions, and choose 

Global Functions > Browser Network > getURL  

Type this in the URL slot: mailto:"your@email.address.com"  (add in your e-mail address in these quotations). This will make it so a visitor to your site will have their email program pop open ready to write to you directly once they click on the button.
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Go back to your Timeline tab (at the very top).

Don’t forget to drag in and setup your Back button again (or you can copy/paste it from another scene).
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Step 27

Return to Scene 1.

Now we have to set all our scenes to stop once the scene is activated.

At your main title page, go to the one keyframe on the top layer, right click on it and choose Actions.

Then click and drag in “stop” from the Timeline Control section.
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When you go back to the Timeline, you’ll notice there’s a small “a” on the keyframe, meaning there’s an action on the timeline.
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Now go and do this to ALL your other scenes. Go click on Scene 2, right click on the first frame, select Actions, drag the “stop” command to the white area, and repeat for the rest of them.

Step 28

Now to get rid of that hideous text you made.

To create a new stylish title, let’s delete the old one by locking all layers except for the one with your title on it, click on the keyframe and hit delete.
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Now open up PHOTOSHOP again for a quick simple text effect tutorial on “layer styles”.
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Step 29

Grab the paint bucket and paint in a color for the background (just so you can see what you’re doing), I chose a red color.

Now, lets create some text, the font I'm using is Verdana, but you can use any sans serif font like Helvetica, Arial, or anything like that. Grab a yellow-orange color for the font.
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Go into your layer styles.

Found in the fx button in the far bottom right corner of your layers window.

Now lets go to the bevel and emboss settings. 

Create a bevel with these settings.
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Now go into the gradient overlay settings of the layer styles. Choose these settings.
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After setting the colors, click OK, and OK again, your window will look like this:
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Finally, go into the drop shadow settings of the layer styles and change your settings to something like I have below.
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Now to prepare it for Flash, make your background invisible by removing the eye icon on the bottom layer.  Then go to File > Save As… and choose the PNG format. Name your file title.png
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If the “Interlaced” options pops up, select it and press OK.

Step 30

Back to FLASH.

Make sure you’re on the top layer. Go to File > Import > Import to Stage…
Choose your title image. Click OK.

BAM you’ve got a transparent background on your awesome bitmap text.
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That’s the power of the PNG file, it preserves the “alpha channel” and eliminates the background you had.

Reposition the text, and blammo! … You’re done! Press Ctrl+Enter to test your movie

Well… sort of.  Keep tweaking and improving, check to see if all the buttons work and do what they’re supposed to do.  This is your final exam (worth 50% of your grade).  Consistency, free of errors, and a nice easy-to-navigate layout are the key factors.  It should function like this: http://www.floobynooby.com/IPUB/assignment9-sample.swf
Step 31

One last thing!

Open up Dreamweaver.

When the program fires up, choose HTML as your new document.

You’ll have a blank page, make sure the “Split” button is on, you’ll know cause you’ll see some code on the screen.
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Now type in the “embed code”  You can copy/paste it from the text below, just replace “myname” with the name of your flash file. Make sure .swf is at the end. Note: it’s the rendered movie file we’re embedding not the Flash file itself.

<embed src="myname_assignment9.swf" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" height="480" width="853">
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Label your file with “your name” and then “index” afterwards (as shown above DO NOT USE SPACES), save it in the same location as your Flash file and SWF file. Open the HTML file in Firefox to test it out. If you wish to make the website centered, add in some <center> open and close tags as shown below.
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For more on basic coding with HTML go here:

http://www.web-source.net/html_codes_chart.htm
That’s it!

This is VERY basic, but still you can see how long it can take to make a website, a very simple one can be done in an hour, but once you add more content, graphics and information it can take several days, not to mention how sophisticated your imagery and graphics can be.

Send the HTML and SWF files 

(with your name in both of the actual file names) to your instructor.

OK, so now we’ve made an SWF file (the rendered all-in-one-self-contained rendered Flash movie file that holds all your scenes, buttons, text and pictures), and we’ve learned the basics of Dreamweaver. Once you have all your content ready to upload, there are a number of open source venues available to you, all without any requirement of prior programming knowledge. 

The following is information for you to keep for when you want to take the plunge and actually PUBLISH your website online.  It’s not entirely that easy (depending on which route you take), but once it’s up it’s very easy to maintain, upkeep and update.  Whether you go the simple route or the hardcore route, the better your website looks and feels the better chance you have at getting a job with it.  It shows you’re professional and care about your own self-marketing/promoting skills.  It can be a lot of work but it’s well worth it once it’s done.

The remainder of this document is not mandatory for you to do, it is only advice for you to use if ever you plan to continue your endeavors in developing and managing your own website. 

1. Creating your website

Using Wordpress

www.Wordpress.org is one of many free content management system that is used by millions of blogging laymen. With it comes a whole system that makes it easy to add new content to your site and already made web design themes for you to choose between. Alternatively, learn more about how to create your own Wordpress theme and full blown website by downloading Wordpress to construct your site in full: www.wordpress.com (this is where you could upload your all-inclusive SWF file and BAM you’re done!  …. Um, once you’ve registered your own domain name and all that first).
If all you want is a very simple, point and click web site to post your words and pictures and nothing else, then www.blogger.com is your best bet. Easy and simple to use, many photographers even go this root to make a fast and efficient online portfolio to showcase some samples of their photography.  Blogs are VERY simple but limited, if you have your resume, pictures and all that ready, then you don’t need Flash or Dreamweaver, blogger will take care of the layout, template and everything for you.  You don’t get your own “.com” and your choice of colors, layouts and aesthetics are a bit limited

Joomla is another free CMS software which basically creates the site for you and eases the task of content administration. The only thing you have to do is to install it properly. In addition to this, you are also normally granted free access to site-building tools when you sign up for a hosting plan. If you want read more about how to start your own website, find out more about how to set up a free website through web hosting here: http://www.webhostingsearch.com/articles/how-to-start-up-a-website.php
Refresher on the basic nerd terminology you should know as you get into actually publishing and managing your own personal website:
Domain – Refers to the initial part of a URL (Uniform Resource Locator. The unique address of any Web document found online), where the domain and name of the host or  server computer are listed (most often in reversed order, name first, then domain). The domain name gives you who "published" a page, made it public by putting it on the Web.

CSS – Cascading Style Sheets – a file ending in .css, which is linked to from the HTML, which controls the look of the rendered page. In Dreamweaver when you construct a page with lots of tables and imported elements like images, sounds, etc, CSS files are created automatically to keep track of all the elements.

HTML – Hyper Text Mark-up Language is the code that forms all websites and describes the content it contains. It is important to understand that ALL websites end up as some form of HTML, regardless of the languages used to build them. For example, a file might be PHP (Hypertext Preprocessor), as in index.php, but ultimately what is served up to the browser is HTML. The file extension PHP just lets the server know to process any of the special PHP code inside before serving it up.

FTP – File Transfer Protocol. Ability to transfer rapidly entire files from one computer to another, intact for viewing or other purposes.

Web Server – A computer running that software, assigned an IP address, and connected to the Internet so that it can provide documents via the World Wide Web. Also called HOST computer. Web servers are the closest equivalent to what in the print world is called the "publisher" of a print document. An important difference is that most print publishers carefully edit the content and quality of their publications in an effort to market them and future publications. This convention is not required in the Web world, where anyone can be a publisher; careful evaluation of Web pages is therefore mandatory.

CMS – Content Management System – a software program that runs on a server with the purpose of making managing the content on the website easier. For example, a site may have hundreds of pages (like this one). Each of those pages does not exist as a separate HTML file. Instead, the content is kept in a database and injected into templates and served up as needed by the CMS.

RSS – Really Simple Syndication is a special (and standards based) form of XML for publishing content. For example, most blogs provide RSS of their content. Other people (even basic users) can take that RSS and use it in different ways, like republishing that content elsewhere, or just reading it through special programs, like Google Reader). May be referred to an an RSS Feed, or even just Feed by itself.

Kerning – Adjusting the spacing between two specific letters, to improve how a word looks aesthetically. Tracking is similar but refers to overall letter spacing.

Sprite – An image that actually contains multiple images. The images are typically displayed cropped down to only show a small area. As counter-intuitive as it seems, this can improve efficiency by requiring less total images to be used.

Vector – A form of graphic where the design is saved as points and mathematical formulas. Because of this, the files are “resolution independent” meaning they can be scaled to any size without losing their crispness. Adobe Illustrator files are vector files (although it is possible for them to contain bitmap data). AI, EPS

Bitmap – A form of graphic that is saved as individual pixels, meaning it has a set resolution and cannot be scaled up or down without affecting its crispness. Adobe Photoshop files are bitmap files (although it is possible for them to contain vector data). JPG, GIF, PNG.

Rendering – the process the browser goes through when interpreting HTML and CSS and turning that into the visual end result you see on your screen. When a website is slowly ‘loading up’ you see text and images gradually appear, this is “rendering”

2. Get a hosting plan

Next step is to find somewhere online to put your website files and assign an address to that somewhere. Any given hosting plan include storage space on a web server and a domain name registration. Depending on what size your website has and potential traffic volume it's going to generate, you get a hosting plan based on three factors - storage space, bandwidth and CPU. Nowadays, there are many qualitative and cheap web hosting plans to choose between: http://www.webhostingsearch.com/cheap-web-hosting.php
For all of you into blogging, there are also many great WordPress web hosts offering cheap hosting that is tailored to support this CMS. 

*Overall WordPress is probably your best bet for a website/blog, it ranges from free to expensive, but if you want to build a web presence, you get what you pay for, try them out for free then explore to see what they have to offer for deals to make full blown websites.

3. Upload your files/Publish your website

Upload your files to the root directory of your purchased web hosting server space. You can do this either by using your hosting account's inhouse file manager, but those are often slow and manage large file volume poorly. Our recomendation is to get your hands on a FTP client. More specifically, a FireFox add-on by the name FireFTP. It will allow you to access your hosting account directly in the web browser and transfer website files with ease: http://fireftp.mozdev.org/
Assuming that you are new to web development, it is important for you to get a website up sooner rather than later, I suggest you follow the steps above. Use open source and the blessing of freeware. Get a hosting plan that matches your needs and publish your files through an FTP client like FireFtp. There will be things to remember and learn along the way, but if you follow these guidelines, publishing a website will not seem so impossible.

Basically you have 4 options, it’s all entirely up to you which one you pick:

1. Publish to a free subdomain and host your site with any online company that offers this service (like those shown in the huge list below).

   2. Purchase a custom top level domain (.com, .net, .biz or .org) and still host your site with us for free.

   3. Publish to a domain you already own and still host your site with any free (on non-free) web hosting company.

   4. Say “screw that” and go for the simple, fast “Blog” method, upload you pictures and texts to a free blog, customize it the best way you can, spread the web address out to your friends, clients, and potential employers. 16 WordPress Sites to Help You Build a Better Blog: http://sixrevisions.com/wordpress/16-wordpress-sites-to-help-you-build-a-better-blog/#more-1930
Remember:

   1. If you select options 1,2 or 3 you can easily make changes to your published site at any time, so there is no need to wait until your site is "finished" before you publish it. Good websites are always "under construction" and you should continue to update your site as often as possible after you publish it.

   2. When you publish your site anyone will be able to view your site by clicking on a link to your site that you provide, or by typing your URL (web address) into the address bar of their browser. However, you will not be able to search for your site immediately as it takes time for newly published sites to be indexed by search engines.
Below is a short list of names and reviews for online free web hosting:

  ZeroCatch 
One of the best free Web hosters that we've seen yet, ZeroCatch offers you 100 megs of space. This banner-ad supported hoster has speedy, reliable servers. Features here include FTP support, site promotion and more. If you're looking for an added draw for your site, check out their "partnership" program, which lets you become a free Web space provider yourself. 


  TopCities.com 
A solid free Web space provider, TopCities.com offers you 150 megabytes of space, unlimited bandwidth, and free subdomains. Here, you upload your files using FTP, or via their online EasyUpload utility. TopCities.com also offers a number of free enhancements for your site, such as a guestbook and a message board. 


  Hostrator 
A free Web hosting service that offers a generous 10 gigs of space, as well as free subdomains. You can upload your content either via your browser or FTP. Hostrator offers 24/7 tech support via E-mail. The service supports PHP and MySQL. 


  BlackAppleHost.com 
A new free Web hosting service that offers a hefty 5 gigs of space and instant account activation. You can upload your content here either via your browser or FTP. BlackAppleHost.com offers lots of features, including detailed traffic stats, as well as support for MySQL and PHP. 


  Hostse 
A free hosting service that gives you a generous 1 gig of disk space, as well as 25 gigs of bandwidth. Hostse offers PHP 5 support, MySQL databases and full FTP access. You may either use your own domain (if you have one), or get a free subdomain. 


  007sites.com 
This is a speedy free Web hosting service that gives you 700 megabytes of space and 7,000 megs of monthly bandwidth. Here, you can get your own subdomain (or you can use your own existing domain). 007sites.com also offers MySQL, PHP, and FTP support. 


  FreeWebPage.org 
This is a solid, free Web hosting service that includes a lot of helpful features. An ad-supported service, FreeWebPage.org gives you 150 megs of space and your own subdomain. Other features include direct FTP access, a guestbook, a message board, form mail and lots more. 


  250Free.com 
A fast-growing free Web hosting service that offers 250 megs of space, as well as top-notch tech support. 250Free.com features an easy-to-use Web-based account manager, as well as FTP access. This service is MSN TV-friendly. 

  1SweetHost.com 
Here's a free, banner-supported Web hosting service that offers you 100 megs of space, along with FTP support, site promotion, and speedy servers. 


  WebNG.com 
This free hosting service offers 350 megs of space and speedy servers. Features here include FTP access, ASP 3.0, SSI, and Microsoft Access database support, along with image, audio and video hosting support. 


  ProHosting.com 
This free Web space provider offers a generous package. Here, you get 50 megs of Web space, an FTP account and CGI access. ProHosting also offers an online site creation utility and customer support via E-mail. 


  Orgfree.com 
Here's a versatile free Web hoster that features domain and subdomain hosting. This service offers "unlimited" Web space and bandwidth and high-traffic sites are eligible for a free domain. Here, you get free FTP access, PHP/MySQL support and more. 


  Free-Webhosts.com 
Are you looking for free Web space? This regularly-updated directory lists over 800 free hosting services on the Web. Free-Webhosts.com offers reviews, ratings and a searchable database. 


  Absolutely-Free-Hosting.com 
Here's a good resource if you're looking for free Web hosting. This site offers a searchable database with reviews of over 200 free hosting services on the Web. The categories here round up hosters by the specific services they offer, including ASP, PHP, domain hosting and more. 


  eSmartStart.com 
A speedy, solid free hosting service which offers 20 megabytes of Web space for your personal or commercial Web site. Esmartstart.com lets you use your own domain name or you may choose from among 12 virtual domains. Here, you get full FTP access, as well as an easy-to-use Web-based file manager. Other features include unlimited E-mail addresses, a guestbook, counter, templates and more. Excellent tech support is provided via E-mail.

  987mb.com 
This popular free hosting service offers 1,987 megs of Web space, as well as instant activation of new sites. 987mb.com has lots of useful features, including MySQL, PHP, a mailbox, tracking stats, and five free subdomains. 


  Profuse Host 
At this free Web hosting service, you get 1,000 megs of space, as well as 100 gigs of monthly bandwidth. Profuse Host offers lots of useful features, including free domain hosting, PHP/MySQL support, CGI access, and more. 


  FindMyFreeHost.com 
This helpful directory offers a nice roundup of free hosting services on the Web. Here, you'll also find listings for commercial hosters, as well as other hosting-related services, such as free domain names and URL hosting services. 


  PurePortals.com 
This free, ad-supported service lets you set up your own portal, complete with features like Web logs, photo galleries, contact lists, announcements, news feeds and more. You also have the option of using your own domain name for your portal at no extra cost. 


  Free Web Hosting Search 
This search engine can help you find a free Web hosting service that fits your needs. Here, you can search by specific features, including ASP, PHP, CGI, MySQL, and more. This site also includes details about the pros and cons of each service. 


  00FreeHost.com 
A speedy free Web hosting service that gives you 100 megs of space and your choice of FTP or browser upload access. Here, you also get free site stats, site promotion help, and your own subdomain address. 


  Free-Webspace.org 
Looking for free hosting for your Web site? This searchable directory offers a good roundup of various free hosters across the Net, along with detailed listings of each service. 


  Best Free Web Space 
This Web space directory offers reviews, descriptions, and ratings of over 100 free hosting companies on the Web, along with a searchable database. 


  1ASPHost.com 
This free Web hosting service offers 100 megs of space, unlimited bandwidth and instant account activation. Features here include Microsoft Access database support; Active Server Pages (ASP) and 24-hour tech support. 


  ImageUploads.com 
A free image hosting service, ImageUploads is easy to use and allows hotlinking. This service is handy for posting pictures on Web sites, forums, eBay auctions, etc. Supported image formats include GIF, JPG and SWF. 


  FreeWebSiteProviders.com 
Looking for a free Web hosting service? This handy directory offers reviews of over 400 free hosters across the Web. The site also features a roundup of free Webmaster services, such as Web page templates, URL redirection services, counters, hosted CGI scripts, graphics and more. 


  Blogger.com

 Would you like to publish on the Web, but don't want the hassle of having to set up a Web site? Then you should explore Blogger, a free online tool that lets you post content on the Web instantly. Blogger, a popular service owned by the search engine Google, lets you quickly and easily set up a custom "blog" (short for "Web log"). 


  FreeWebSpace.com 
A solid, free, ad-supported Web hosting service, FreeWebSpace.com gives you 100 megs of space, along with site promotion and enhancement tools. You can use either their Web-based file manager, or an FTP client, to upload your files. 


  FortuneCity.com 
Stake your claim at this major free Web space provider that uses a city theme. Some people will probably find this concept appealing; others are annoyed by it, judging from our feedback. Fortune City.com offers 1 gig of space and they've added subdirectory support, making it easier to manage your files.

  Angelfire.com 
A major free Web space provider that is owned by search portal Lycos, Angelfire offers 20 megabytes of space and supports FrontPage extensions. You may advertise your business here, but you may not have paid advertising banners on your page. Angelfire offers lots of helpful advice for getting you up and running with your own Web site, even if you're new to Web site authoring. 


  WebSpawner.com 
WebSpawner is a free online Web authoring system that lets you design and develop customized Web pages in a matter of minutes - without having to learn HTML. 


SPEND MONEY – GET MORE BANDWIDTH AND SPEED FOR $4+ PER MONTH:

http://www.hostmonster.com/
http://www.arvixe.com/
http://www.hostclear.com/
http://www.fatcow.com/
http://www.justhost.com/
http://www.zooloo.com/
